Cannot RDP To Windows 2008 R2 Server After Upgrading To SP1

 

Remote access is lost after upgrading Windows 2008 R2 RTM server to SP1! How to fix it?

I know that SP1 for 2008 R2 has been out for a while and any new server builds should have it by default. But not all companies have their builds upgraded to SP1. I came across this issue while patching a 2008 R2 RTM server before installing Exchange 2010.

The issue was that the base RTM build had Security Hotfix 2667402. From the KB article, following paragraph got my attention.

After you install security update 2667402 on a computer that is running Windows 7 or Windows Server 2008 R2, and then you install Service Pack 1 (SP1) for Windows 7 or for Windows Server 2008 R2, the binary version of Rdpcorekmts.dll is 6.1.7600.16952 and not 6.1.7601.17767. In this scenario, you may be unable to create a remote desktop session to control the Windows 7-based or Windows Server 2008 R2-based computer.

This issue occurs because the SP1 binary version of Rdpcorekmts.dll was not originally deployed when security update 2667402 was originally installed.

On June 12, 2012, security update 2667402 was rereleased to address this issue. Customers who are running Windows 7 or Windows Server 2008 R2 should install the reoffered update. This includes those who already successfully installed the update that was originally offered on March 13, 2012.

The fix was to remove the hotfix 2667402 via ILO.

No rdp access after upgrading Windows 2008 R2 server to SP1

After the server was restarted, I could establish an RDP session. Microsoft recommends to reinstall the same hotfix which was re-released in June 2012.

Your Thoughts?