The “IIS 6 WMI Compatibility” Component Is Required Error While Upgrading To Exchange 2010 SP2…

Share & Comment

While upgrading to Exchange 2010 SP2 using the GUI, you will come across the error message shown below. This only happens while upgrading the CAS role.

IIS 6 WMI Required for Exch 2010 SP2 Upgrade

The reason is that the CAS requires a new pre-requisite for supporting OWA mini (a new feature in SP2). Hence, either install it using Server Manager (right click “Web Server” and add role service) or Windows PowerShell.

IIS 6 WMI

To install using PowerShell, run Import-Module ServerManager followed by Add-WindowsFeature Web-WMI.

Install Web-WMI

Another option is to run the setup from the command line, Setup.Com /mode:upgrade /InstallWindowsComponents

Happy upgrading Winking smile

Share & Comment
Subscribe for Updates
Never miss a blog post again

7 thoughts on “The “IIS 6 WMI Compatibility” Component Is Required Error While Upgrading To Exchange 2010 SP2…

  1. Marlboro

    Thanks,some great data here keep up the good work. I actually allow for a more creative comment as I’m a bit out of my depth but I will be checking back here for further updates.
    Regards,

    Reply
  2. Phil

    I upgraded our Exchange 2010 SP1 on the weekend to SP2 with Rollup 1 – now have no Free/Busy data for Outlook clients. <9 months exp btw.

    Reply
  3. jigs

    Its work in my case. But we should close the EMS console when upgrade the Exch2010 SP2 otherwise its getting error.

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>