Exchange 2010 SP3 Released

Exchange Team has released service pack 3 for 2010 deployments.The service pack was scheduled for Q1 of 2013 and the wait is over now! Exchange 2010 SP3 allows 2010 servers to coexist with Exchange 2013 CU1, which is also scheduled to be released in Q1 2013. 2010 SP3 brings update to AD & database schema. [...]

Read More

Exchange 2013 – Is Office 2010 Filter Pack Required?

The short answer is NO and let’s find out why that is the case. Every exchange admin is familiar with the Office Filter packs, which is installed as a prerequisite in Exchange 2007 & 2010 to index and search Office files. The story is different in Exchange 2013? We don’t need to install Office 2010 [...]

Read More

Service Pack 3 For Office For Mac 2011 Released

Microsoft has released service pack 3 for Office for Mac 2011.One thing to note is that this update does not include an uninstall feature. To restore your application to its original state, you have to delete it from your hard disk, reinstall it from your original installation disk and then install the updates you want. [...]

Read More

Two Exchange 2013 Videos In TechNet

Two Exchange 2013 videos are online in TechNet!The first one is around what is new in Exchange 2013 and can be viewed here. The second one goes into architecture, best practices and client access & can be viewed here. Both videos are about an hour long and it is one of the best ways to [...]

Read More

Rollup 3 For TMG 2010 SP2 Released

Microsoft has released update rollup 3 for TMG 2010 SP2.It is good to know that Microsoft hasn’t forgotten about TMG even though there won’t be future versions of the product. To install this update, you must be running Forefront Threat Management Gateway 2010 Service Pack 2 and you don’t have to restart the server after [...]

Read More

Happy New Year

I wish all my readers a very happy year ahead. (From Google Images) I will try to be regular with articles this year ;)

Read More

Provisioning Layer Initialization Failed: ‘Failed To Reconnect To Active Directory Server. Make Sure The Server Is Available And That You Have Used The Correct Credentials.

I came across this strange error while installing Exchange 2010 SP2 on a brand new server running Windows 2008 R2 SP1. [ERROR] The following error was generated when "$error.Clear(); & $RoleBinPath\ServiceControl.ps1 EnableServices $RoleRoleName.Replace('Role','') " was run: "Provisioning layer initialization failed: 'Failed to reconnect to Active Directory server DC.Domain.Local. Make sure the server is available, and [...]

Read More

Version 2 Update Rollup 5 For Exchange 2010 SP2 Released

Version 2 of rollups have become so common these days ;)The Exchange Team has released version 2 of the Update Rollup 5 for Exchange 2010 SP2 deployments. The version 1 was released a few weeks back, but was withdrawn due to a DAG related bug. As usual, any interim updates from Microsoft PSS should be [...]

Read More

Cannot RDP To Windows 2008 R2 Server After Upgrading To SP1

Remote access is lost after upgrading Windows 2008 R2 RTM server to SP1! How to fix it?I know that SP1 for 2008 R2 has been out for a while and any new server builds should have it by default. But not all companies have their builds upgraded to SP1. I came across this issue while [...]

Read More

Exchange 2013 EAC – Turn Off Internet Access

With Exchange 2013 administration moving to browser based, you can manage your Exchange 2013 environment from anywhere in the world, provided that they are published. How can we switch off access from outside the corporate network? You can manage your 2013 environment with EAC internally by navigating to https://casserver/ecp or https://loadbalancedurl/ecp if you have an [...]

Read More